The laboratory work 5
Defining and deploying a cube
To define a dimension
1. In Solution Explorer (on the right side of Microsoft Visual Studio), right-click Dimensions, and then click New Dimension. The Dimension Wizard appears.
2. On the Welcome to the Dimension Wizard page, click Next.
3. On the Select Creation Method page, verify that the Use an existing table option is selected, and then click Next.
4. On the Specify Source Information page, verify that the Adventure Works DW 2012 data source view is selected.
5. In the Main table list, select Date.
6. Click Next.
7. On the Select Dimension Attributes page, select the check boxes next to the following attributes:
· Date Key
· Full Date Alternate Key
· English Month Name
· Calendar Quarter
· Calendar Year
· Calendar Semester
8. Change the setting of the Full Date Alternate Key attribute's Attribute Type column from Regular to Date. To do this, click Regular in the Attribute Type column. Then click the arrow to expand the options. Next, click Date > Calendar > Date. Click OK. Repeat these steps to change the attribute type of the attributes as follows:
· English Month Name to Month
· Calendar Quarter to Quarter
· Calendar Year to Year
· Calendar Semester to Half Year
9. Click Next.
10. On the Completing the Wizard page, in the Preview pane, you can see the Date dimension and its attributes.
11. Click Finish to complete the wizard.
In Solution Explorer, in the Analysis Services Tutorial project, the Date dimension appears in the Dimensions folder. In the center of the development environment, Dimension Designer displays the Date dimension.
12. On the File menu, click Save All.
The Cube Wizard helps you define the measure groups and dimensions for a cube. In the following task, you will use the Cube Wizard to build a cube.
To define a cube and its properties
1. In Solution Explorer, right-click Cubes, and then click New Cube. The Cube Wizard appears.
2. On the Welcome to the Cube Wizard page, click Next.
3. On the Select Creation Method page, verify that the Use existing tables option is selected, and then click Next.
4. On the Select Measure Group Tables page, verify that the Adventure Works DW 2012 data source view is selected.
5. Click Suggest to have the cube wizard suggest tables to use to create measure groups.
The wizard examines the tables and suggests InternetSales as a measure group table. Measure group tables, also called fact tables, contain the measures you are interested in, such as the number of units sold.
6. Click Next.
7. On the Select Measures page, review the selected measures in the Internet Sales measure group, and then clear the check boxes for the following measures:
· Promotion Key
· Currency Key
· Sales Territory Key
· Revision Number
By default, the wizard selects as measures all numeric columns in the fact table that are not linked to dimensions. However, these four columns are not actual measures. The first three are key values that link the fact table with dimension tables that are not used in the initial version of this cube.
8. Click Next.
9. On the Select Existing Dimensions page, make sure the Date dimension that you created earlier is selected, and then click Next.
10. On the Select New Dimensions page, select the new dimensions to be created. To do this, verify that the Customer, Geography, and Product check boxes are selected, and then clear the InternetSales check box.
11. Click Next.
12. On the Completing the Wizard page, change the name of the cube to Analysis Services Tutorial. In the Preview pane, you can see the InternetSales measure group and its measures. You can also see the Date, Customer, and Product dimensions.
13. Click Finish to complete the wizard.
In Solution Explorer, in the Analysis Services Tutorial project, the Analysis Services Tutorial cube appears in the Cubes folder, and the Customer and Product database dimensions appear in the Dimensions folder. Additionally, in the center of the development environment, the Cube Structure tab displays the Analysis Services Tutorial cube.
14. On the toolbar of the Cube Structure tab, change the Zoom level to 50 percent, so that you can more easily see the dimensions and fact tables in the cube. Notice that the fact table is yellow and the dimension tables are blue.
15. On the File menu, click Save All.
Adding Attributes to the Customer Dimension
To add attributes
1. Open Dimension Designer for the Customer dimension. To do this, double-click the Customer dimension in the Dimensions node of Solution Explorer.
2. In the Attributes pane, notice the Customer Key and Geography Key attributes that were created by the Cube Wizard.
3. On the toolbar of the Dimension Structure tab, make sure the Zoom icon to view the tables in the Data Source View pane is set at 100 percent.
4. Drag the following columns from the Customer table in the Data Source View pane to the Attributes pane:
· BirthDate
· MaritalStatus
· Gender
· EmailAddress
· YearlyIncome
· TotalChildren
· NumberChildrenAtHome
· EnglishEducation
· EnglishOccupation
· HouseOwnerFlag
· NumberCarsOwned
· Phone
· DateFirstPurchase
· CommuteDistance
5. Drag the following columns from the Geography table in the Data Source View pane to the Attributes pane:
· City
· StateProvinceName
· EnglishCountryRegionName
· PostalCode
6. On the File menu, click Save All.
Adding Attributes to the Product Dimension
To add attributes
1. Open Dimension Designer for the Product dimension. Double-click the Product dimension in Solution Explorer.
2. In the Attributes pane, notice the Product Key attribute that was created by the Cube Wizard.
3. On the toolbar of the Dimension Structure tab, make sure the Zoom icon to view the tables in the Data Source View pane is set at 100 percent.
4. Drag the following columns from the Product table in the Data Source View pane to the Attributes pane:
· StandardCost
· Color
· SafetyStockLevel
· ReorderPoint
· ListPrice
· Size
· SizeRange
· Weight
· DaysToManufacture
· ProductLine
· DealerPrice
· Class
· Style
· ModelName
· StartDate
· EndDate
· Status
5. On the File menu, click Save All.
To review cube and dimension properties in Cube Designer
1. To open the Cube Designer, double-click the Analysis Services Tutorial cube in the Cubes node of Solution Explorer.
2. In the Measures pane of the Cube Structure tab in Cube Designer, expand the Internet Sales measure group to reveal the defined measures.
You can change the order by dragging the measures into the order that you want. The order you create affects how certain client applications order these measures. The measure group and each measure that it contains have properties that you can edit in the Properties window.
3. In the Dimensions pane of the Cube Structure tab in Cube Designer, review the cube dimensions that are in the Analysis Services Tutorial cube.
Notice that although only three dimensions were created at the database level, as displayed in Solution Explorer, there are five cube dimensions in the Analysis Services Tutorial cube. The cube contains more dimensions than the database because the Date database dimension is used as the basis for three separate date-related cube dimensions, based on different date-related facts in the fact table. These date-related dimensions are also called role playing dimensions. The three date-related cube dimensions let users dimension the cube by three separate facts that are related to each product sale: the product order date, the due date for fulfillment of the order, and the ship date for the order. By reusing a single database dimension for multiple cube dimensions, Analysis Services simplifies dimension management, uses less disk space, and reduces overall processing time.
4. In the Dimensions pane of the Cube Structure tab, expand Customer, and then click Edit Customer to open the dimension in Dimension Designer.
Dimension Designer contains these tabs: Dimension Structure, Attribute Relationships, Translations, and Browser. Notice that the Dimension Structure tab includes three panes: Attributes, Hierarchies, and Data Source View. The attributes that the dimension contains appear in the Attributes pane. For more information, see Dimension Attribute Properties Reference, Create User-Defined Hierarchies, and Define Attribute Relationships.
5. To switch to Cube Designer, right-click the Analysis Services Tutorial cube in the Cubes node in Solution Explorer, and then click View Designer.
6. In Cube Designer, click the Dimension Usage tab.
In this view of the Analysis Services Tutorial cube, you can see the cube dimensions that are used by the Internet Sales measure group. Also, you can define the type of relationship between each dimension and each measure group in which it is used.
7. Click the Partitions tab.
The Cube Wizard defines a single partition for the cube, by using the multidimensional online analytical processing (MOLAP) storage mode without aggregations. With MOLAP, all leaf-level data and all aggregations are stored within the cube for maximum performance. Aggregations are precalculated summaries of data that improve query response time by having answers ready before questions are asked. You can define additional partitions, storage settings, and writeback settings on the Partitions tab. For more information, see Partitions (Analysis Services - Multidimensional Data), Aggregations and Aggregation Designs.
8. Click the Browser tab.
Notice that the cube cannot be browsed because it has not yet been deployed to an instance of Analysis Services. At this point, the cube in the Analysis Services Tutorial project is just a definition of a cube, which you can deploy to any instance of Analysis Services. When you deploy and process a cube, you create the defined objects in an instance of Analysis Services and populate the objects with data from the underlying data sources.
9. In Solution Explorer, right-click Analysis Services Tutorial in the Cubes node, and then click View Code. You might need to wait.
The XML code for the Analysis Services Tutorial cube is displayed on the Analysis Services Tutorial.cube [XML] tab. This is the actual code that is used to create the cube in an instance of Analysis Services during deployment. For more information, see View the XML for an Analysis Services Project (SSDT).
10. Close the XML code tab.
To deploy the Analysis Services project
1. In Solution Explorer, right-click the Analysis Services Tutorial project, and then click Properties.
The Analysis Services Tutorial Property Pages dialog box appears and displays the properties of the Active (Development) configuration. You can define multiple configurations, each with different properties. For example, a developer might want to configure the same project to deploy to different development computers and with different deployment properties, such as database names or processing properties. Notice the value for the Output Path property. This property specifies the location in which the XMLA deployment scripts for the project are saved when a project is built. These are the scripts that are used to deploy the objects in the project to an instance of Analysis Services.
2. In the Configuration Properties node in the left pane, click Deployment.
Review the deployment properties for the project. By default, the Analysis Services Project template configures an Analysis Services project to incrementally deploy all projects to the default instance of Analysis Services on the local computer, to create an Analysis Services database with the same name as the project, and to process the objects after deployment by using the default processing option. For more information, see Configure Analysis Services Project Properties (SSDT).
3. Click OK.
4. In Solution Explorer, right-click the Analysis Services Tutorial project, and then click Deploy. You might need to wait.
SQL Server Data Tools builds and then deploys the Analysis Services Tutorial project to the specified instance of Analysis Services by using a deployment script. The progress of the deployment is displayed in two windows: the Output window and the Deployment Progress - Analysis Services Tutorial window.
Open the Output window, if necessary, by clicking Output on the View menu. The Output window displays the overall progress of the deployment. The Deployment Progress - Analysis Services Tutorial window displays the detail about each step taken during deployment. For more information, see Build Analysis Services Projects (SSDT) and Deploy Analysis Services Projects (SSDT).
5. Review the contents of the Output window and the Deployment Progress - Analysis Services Tutorial window to verify that the cube was built, deployed, and processed without errors.
6. To hide the Deployment Progress - Analysis Services Tutorial window, click the Auto Hide icon (it looks like a pushpin) on the toolbar of the window.
7. To hide the Output window, click the Auto Hide icon on the toolbar of the window.
After you deploy a cube, the cube data is viewable on the Browser tab in Cube Designer, and the dimension data is viewable on the Browser tab in Dimension Designer. Browsing cube and dimension data is way to check your work incrementally. You can verify that small changes to properties, relationships, and other objects have the desired effect once the object is processed. While the Browser tab is used to view both cube and dimension data, the tab provides different capabilities based on the object you are browsing.
For dimensions, the Browser tab provides a way to view members or navigate a hierarchy all the way down to the leaf node. You can browse dimension data in different languages, assuming you have added the translations to your model.
For cubes, the Browser tab provides two approaches for exploring data. You can use the built-in MDX Query Designer to build queries that return a flattened rowset from a multidimensional database. Alternatively, you can use an Excel shortcut. When you start Excel from within SQL Server Data Tools, Excel opens with a PivotTable already in the worksheet and a predefined connection to the model workspace database.
Excel generally offers a better browsing experience because you can explore cube data interactively, using horizontal and vertical axes to analyze the relationships in your data. In contrast, the MDX Query Designer is limited to a single axis. Moreover, because the rowset is flattened, you do not get the drilldown that an Excel PivotTable provides. As you add more dimensions and hierarchies to your cube, which you will do in subsequent lessons, Excel will be the preferred solution for browsing data.
To browse the deployed cube
1. Switch to Dimension Designer for the Product dimension in SQL Server Data Tools. To do this, double-click the Product dimension in the Dimensions node of Solution Explorer.
2. Click the Browser tab to display the All member of the Product Key attribute hierarchy. In lesson three, you will define a user hierarchy for the Product dimension that will let you browse the dimension.
3. Switch to Cube Designer in SQL Server Data Tools. To do this, double-click the Analysis Services Tutorial cube in the Cubes node of Solution Explorer.
4. Select the Browser tab, and then click the Reconnect icon on the toolbar of the designer.
The left pane of the designer shows the objects in the Analysis Services Tutorial cube. On the right side of the Browser tab, there are two panes: the upper pane is the Filter pane, and the lower pane is the Data pane. In an upcoming lesson, you will use the cube browser to do analysis.

